# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^\+)[^\d\r\n]+//gm;t' <<< "+614a24569953
+614a24569953+"