use strict;
my $str = '+614a24569953
+614a24569953+';
my $regex = qr/(?!^\+)[^\d\r\n]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";