using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S|\btype )[^\/\s&=;,<>""'()]*(?:\/[^""'\n;})\s]+)+";
string input = @"Location: /user/login.php xx... /user/login xx... text/html abcd type text/html hey abc/def
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}