$re = '/(?<!\S|\btype )[^\/\s&=;,<>"\'()]*(?:\/[^"\'\n;})\s]+)+/m';
$str = 'Location: /user/login.php xx... /user/login xx... text/html abcd type text/html hey abc/def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);