re = /(?<!\S|\btype )[^\/\s&=;,<>"'()]*(?:\/[^"'\n;})\s]+)+/m
str = 'Location: /user/login.php xx... /user/login xx... text/html abcd type text/html hey abc/def
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end