using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\.\d+)?A?";
string input = @"
<li>ampere à 3A 3.5 Ampere 3.5A .A ne pas prendre</li>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}