re = /\d+(\.\d+)?A?/
str = '
<li>ampere à 3A 3.5 Ampere 3.5A .A ne pas prendre</li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end