$re = '/\d+(\.\d+)?A?/';
$str = '
<li>ampere à 3A 3.5 Ampere 3.5A .A ne pas prendre</li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);