using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^($|#|_)*";
string input = @"#_PHYSICIANS-->PHYSICIANS
##_#_PHYSICIANS-->PHYSICIANS
##_#PHYSICIANS_#_NAME-->PHYSICIANS#_NAME";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}