re = /^($|#|_)*/m
str = '#_PHYSICIANS-->PHYSICIANS
##_#_PHYSICIANS-->PHYSICIANS
##_#PHYSICIANS_#_NAME-->PHYSICIANS#_NAME'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end