package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^($|#|_)*`)
var str = `#_PHYSICIANS-->PHYSICIANS
##_#_PHYSICIANS-->PHYSICIANS
##_#PHYSICIANS_#_NAME-->PHYSICIANS#_NAME`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}