use strict;
my $str = 'Jul 30 00:00:41 rpi dnsmasq[571]: query[A] officescan.corp.arcon.com.br from 192.168.5.187
Jul 30 00:00:43 rpi dnsmasq[571]: query[A] teams.events.data.microsoft.com from 192.168.5.187
Jul 30 00:00:43 rpi dnsmasq[571]: forwarded teams.events.data.microsoft.com to 1.0.0.1
Jul 30 00:00:43 rpi dnsmasq[571]: forwarded teams.events.data.microsoft.com to 1.1.1.1
Jul 30 00:00:43 rpi dnsmasq[571]: reply teams.events.data.microsoft.com is <CNAME>
Jul 30 00:00:43 rpi dnsmasq[571]: reply teams-events-data.trafficmanager.net is <CNAME>
Jul 30 00:00:43 rpi dnsmasq[571]: reply skypedataprdcolweu02.cloudapp.net is 52.114.74.43
';
my $regex = qr/\w{3}\s\d{2}\s\d{2}:\d{2}:\d{2}\s\w+\s\w+\[\d+\]:\squery\[\w+\]\s([\da-z\.-]+\.[a-z]{2,6})\s\w+\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}