# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|^(?=\d+$))\d*?\K456/999/gm;t' <<< "4564567890"