$re = '/(?:\G(?!^)|^(?=\d+$))\d*?\K456/m';
$str = '4564567890';
$subst = "999";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;