re = /(?:\G(?!^)|^(?=\d+$))\d*?\K456/m
str = '4564567890'
subst = '999'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result