package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<service_name>[^-]+)-(?<host>[^:]+):(?<port>\d+)`)
var str = `metics-ha-5924590-011.aba.corp.tyos.com:2002`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}