re = /(?<service_name>[^-]+)-(?<host>[^:]+):(?<port>\d+)/m
str = 'metics-ha-5924590-011.aba.corp.tyos.com:2002'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end