$re = '/(?<service_name>[^-]+)-(?<host>[^:]+):(?<port>\d+)/m';
$str = 'metics-ha-5924590-011.aba.corp.tyos.com:2002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);