const regex = /^(.*?)(?<!\d)\d{5}(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(?<!\\d)\\d{5}(?!\\d)', 'gm')
const str = `;SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);