re = /^(.*?)(?<!\d)\d{5}(?!\d)/m
str = ';SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result