import re
regex = re.compile(r"^(.*?)(?<!\d)\d{5}(?!\d)", flags=re.MULTILINE)
test_str = ";SUPER U CHARLY SUR MARNE;;;rte de Pavant CHARLY SUR MARNE Picardie 02310;Charly-sur-Marne;;;02310;;;;;;;;;;;;;;"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)