#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:^|(?<=[\D;a-zA-Z(),.:;?!"'`>]))(?!000|666|9)(?<![Oo][Rr][Dd][Ee][Rr].)(?<![Oo][Rr][Dd][Ee][Rr]..)(?<![Oo][Rr][Dd][Ee][Rr]...)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr].)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr]..)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr]...)(?<![Xx])\d{3}[ -.=\n\r]{0,10}(?!00)\d{2}[ -.=\n\r]{0,10}(?!0000)\d{4}(?:$|(?=[\Da-zA-Z(),.:;?!"'`<= ]))"
Local $sString = "Order numbers should not get detected if 'X or x' precedes the number. so this is working fine." & @CRLF & _
"x123456789" & @CRLF & _
"X123456789" & @CRLF & _
"x123-456-789" & @CRLF & _
"X123-456-789" & @CRLF & _
"123-456-789" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Need to modify the regex pattern to get the match for the list of ordernumbers written like below...along with the word (order number) should be case insensitive. " & @CRLF & _
"" & @CRLF & _
"ordernumber123-456-789" & @CRLF & _
"order number123-456789" & @CRLF & _
"order number 123456789" & @CRLF & _
"123-456789" & @CRLF & _
"123456789" & @CRLF & _
"ordernumber-123456787" & @CRLF & _
"ordernumber - 123456789" & @CRLF & _
"ordernumber #123456789" & @CRLF & _
"ordernumber *anysplcharacter*123456789" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")