# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|(?<=[\D;a-zA-Z(),.:;?!\"'`>]))(?!000|666|9)(?<![Oo][Rr][Dd][Ee][Rr].)(?<![Oo][Rr][Dd][Ee][Rr]..)(?<![Oo][Rr][Dd][Ee][Rr]...)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr].)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr]..)(?<![Oo][Rr][Dd][Ee][Rr].[Nn][Uu][Mm][Bb][Ee][Rr]...)(?<![Xx])\d{3}[ -.=\n\r]{0,10}(?!00)\d{2}[ -.=\n\r]{0,10}(?!0000)\d{4}(?:$|(?=[\Da-zA-Z(),.:;?!\"'`<= ]))"
test_str = ("Order numbers should not get detected if 'X or x' precedes the number. so this is working fine.\n"
"x123456789\n"
"X123456789\n"
"x123-456-789\n"
"X123-456-789\n"
"123-456-789\n\n\n"
"Need to modify the regex pattern to get the match for the list of ordernumbers written like below...along with the word (order number) should be case insensitive. \n\n"
"ordernumber123-456-789\n"
"order number123-456789\n"
"order number 123456789\n"
"123-456789\n"
"123456789\n"
"ordernumber-123456787\n"
"ordernumber - 123456789\n"
"ordernumber #123456789\n"
"ordernumber *anysplcharacter*123456789\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.