#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)((?<key>order\s*number).*)?(?<!x)(?<value>\d{9}|\d{3}-\d{6}|\d{3}-\d{3}-\d{3})"
Local $sString = "x123456789" & @CRLF & _
"X123456789" & @CRLF & _
"x123-456-789" & @CRLF & _
"X123-456-789" & @CRLF & _
"" & @CRLF & _
"123-456-789" & @CRLF & _
"" & @CRLF & _
"ordernumber123-456-789" & @CRLF & _
"order number123-456789" & @CRLF & _
"order number 123456789" & @CRLF & _
"" & @CRLF & _
"123-456789" & @CRLF & _
"123456789" & @CRLF & _
"" & @CRLF & _
"ordernumber-x123456787" & @CRLF & _
"" & @CRLF & _
"ordernumber-123456787" & @CRLF & _
"ordernumber - 123456789" & @CRLF & _
"ordernumber #123456789" & @CRLF & _
"ordernumber *anysplcharacter*123456789" & @CRLF & _
"ordernumber !@#$%^&123456789" & @CRLF & _
"" & @CRLF & _
"ordernumber !@#$%^&x123456789" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")