import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<key>order\\s*number).*)?(?<!x)(?<value>\\d{9}|\\d{3}-\\d{6}|\\d{3}-\\d{3}-\\d{3})";
final String string = "x123456789\n"
+ "X123456789\n"
+ "x123-456-789\n"
+ "X123-456-789\n\n"
+ "123-456-789\n\n"
+ "ordernumber123-456-789\n"
+ "order number123-456789\n"
+ "order number 123456789\n\n"
+ "123-456789\n"
+ "123456789\n\n"
+ "ordernumber-x123456787\n\n"
+ "ordernumber-123456787\n"
+ "ordernumber - 123456789\n"
+ "ordernumber #123456789\n"
+ "ordernumber *anysplcharacter*123456789\n"
+ "ordernumber !@#$%^&123456789\n\n"
+ "ordernumber !@#$%^&x123456789\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}