# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<key>order\s*number).*)?(?<!x)(?<value>\d{9}|\d{3}-\d{6}|\d{3}-\d{3}-\d{3})"
test_str = ("x123456789\n"
"X123456789\n"
"x123-456-789\n"
"X123-456-789\n\n"
"123-456-789\n\n"
"ordernumber123-456-789\n"
"order number123-456789\n"
"order number 123456789\n\n"
"123-456789\n"
"123456789\n\n"
"ordernumber-x123456787\n\n"
"ordernumber-123456787\n"
"ordernumber - 123456789\n"
"ordernumber #123456789\n"
"ordernumber *anysplcharacter*123456789\n"
"ordernumber !@#$%^&123456789\n\n"
"ordernumber !@#$%^&x123456789\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.