import re
regex = re.compile(r"\b(?:http|ws)s?:\/\/\S*\w\/?", flags=re.MULTILINE)
test_str = ("\"Hello everyone! please join us at: https://oursite.com/. and \n"
"please visit our courses websites: http://courseone.com.eu & http://coursetwo.us. \n"
"For prod use websocket with this url: wss://localhost:4500/websocket/. and \n"
"for staging use this url: ws://localhost:4500/websocket\".")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")