package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-1][0-9]{2}|[0-9]{1,2})$`)
var str = `0
1
2
00
11
22
99
100
000
199
200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}