$re = '/^([0-1][0-9]{2}|[0-9]{1,2})$/m';
$str = '0
1
2
00
11
22
99
100
000
199
200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);