const regex = /^([0-1][0-9]{2}|[0-9]{1,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-1][0-9]{2}|[0-9]{1,2})$', 'gm')
const str = `0
1
2
00
11
22
99
100
000
199
200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}