# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Execution error for request [0-9]+. Reason: ESS-07033 Job logic indicated a system error occurred while executing an asynchronous java job for request [0-9]+. Job error is: one or more subbatches has failed to generate feed..*)/$1|959361986/;t' <<< "2023-06-26 00:00:00|Execution error for request 52262275. Reason: ESS-07033 Job logic indicated a system error x while executing an asynchronous java job for request 52262275. Job error is: one or more subbatches has failed to generate feed.|111975431"