// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Execution error for request [0-9]+. Reason: ESS-07033 Job logic indicated a system error occurred while executing an asynchronous java job for request [0-9]+. Job error is: one or more subbatches has failed to generate feed..*)").unwrap();
let string = "2023-06-26 00:00:00|Execution error for request 52262275. Reason: ESS-07033 Job logic indicated a system error x while executing an asynchronous java job for request 52262275. Job error is: one or more subbatches has failed to generate feed.|111975431";
let substitution = "$1|959361986";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}