import Foundation
let pattern = #"(Execution error for request [0-9]+. Reason: ESS-07033 Job logic indicated a system error occurred while executing an asynchronous java job for request [0-9]+. Job error is: one or more subbatches has failed to generate feed..*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2023-06-26 00:00:00|Execution error for request 52262275. Reason: ESS-07033 Job logic indicated a system error x while executing an asynchronous java job for request 52262275. Job error is: one or more subbatches has failed to generate feed.|111975431"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1|959361986"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}