package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(<noscript>)[\s\S]+?<\/noscript>|<style(.+?)>(.+?)<\/style>`)
var str = `<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, viewport-fit=cover" />
<style type="text/css"></style>
<noscript><style>
< / style></noscript>
<!-- Twitter Cards Meta by USM STARTS-->
<meta name="twitter:card" content="summary" />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="pingback" href="/xmlrpc.php">
<noscript><style>
< / style></noscript>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}