// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(<noscript>)[\s\S]+?<\/noscript>|<style(.+?)>(.+?)<\/style>").unwrap();
let string = "<!DOCTYPE html>
<html lang=\"en-US\">
<head>
<meta charset=\"UTF-8\">
<meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, viewport-fit=cover\" />
<style type=\"text/css\"></style>
<noscript><style>
< / style></noscript>
<!-- Twitter Cards Meta by USM STARTS-->
<meta name=\"twitter:card\" content=\"summary\" />
<style type=\"text/css\">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel=\"pingback\" href=\"/xmlrpc.php\">
<noscript><style>
< / style></noscript>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}