# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<noscript>)[\s\S]+?<\/noscript>|<style(.+?)>(.+?)<\/style>"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en-US\">\n"
"<head>\n"
" <meta charset=\"UTF-8\">\n"
" <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, viewport-fit=cover\" /> \n"
" <style type=\"text/css\"></style>\n"
"<noscript><style>\n\n"
"< / style></noscript>\n"
" <!-- Twitter Cards Meta by USM STARTS-->\n"
" <meta name=\"twitter:card\" content=\"summary\" />\n\n"
" \n"
" <style type=\"text/css\">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>\n\n"
"<link rel=\"pingback\" href=\"/xmlrpc.php\">\n"
"<noscript><style>\n\n"
"< / style></noscript>\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.