#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d*(?:[ -]?(?:[a-zA-Z]+|[1-9]\d*))?$"
Local $sString = "25" & @CRLF & _
"25 a" & @CRLF & _
"25b" & @CRLF & _
"25-ab" & @CRLF & _
"12-14" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"21" & @CRLF & _
"1a" & @CRLF & _
"121 b" & @CRLF & _
"25A" & @CRLF & _
"25 a" & @CRLF & _
"1 a1" & @CRLF & _
"1a1" & @CRLF & _
"12ab12" & @CRLF & _
"0" & @CRLF & _
"b" & @CRLF & _
"0a" & @CRLF & _
"00a" & @CRLF & _
"a a" & @CRLF & _
"00 a" & @CRLF & _
"13àâäèéêë" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")