const regex = /^.*?<\w+:(?<severity>.*?)>.*?3PAR.*?\s(?<command>[^\s]+)\s(?<process>.*?)\s\{(?<sessiontype>.*?)\{.*?\s-\d+\s+(?<sip>[^\s]+)\s(?<sport>[^\s]+)\}\s+(?<action>.*?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?<\\w+:(?<severity>.*?)>.*?3PAR.*?\\s(?<command>[^\\s]+)\\s(?<process>.*?)\\s\\{(?<sessiontype>.*?)\\{.*?\\s-\\d+\\s+(?<sip>[^\\s]+)\\s(?<sport>[^\\s]+)\\}\\s+(?<action>.*?)$', 'gm')
const str = `11 04 2018 04:42:49 192.168.1.103 <USER:INFO> Nov 4 04:42:49 3PAR_1674318 cli_command sw_cli {3paradm super all {{0 8}} -1 192.168.100.53 2314} {setcurrentdomain -} {}
11 04 2018 09:50:15 192.168.1.103 <USER:INFO> Nov 4 09:50:15 3PAR_1674318 cli_command sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 15684} {geteventlog -debug -startt 1541339406 -endt 1541343012 -fprefix {} -tok 0 -fnum 0 -prstate 0 -prnode 0} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}