import Foundation
let pattern = #"^.*?<\w+:(?<severity>.*?)>.*?3PAR.*?\s(?<command>[^\s]+)\s(?<process>.*?)\s\{(?<sessiontype>.*?)\{.*?\s-\d+\s+(?<sip>[^\s]+)\s(?<sport>[^\s]+)\}\s+(?<action>.*?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
11 04 2018 04:42:49 192.168.1.103 <USER:INFO> Nov 4 04:42:49 3PAR_1674318 cli_command sw_cli {3paradm super all {{0 8}} -1 192.168.100.53 2314} {setcurrentdomain -} {}
11 04 2018 09:50:15 192.168.1.103 <USER:INFO> Nov 4 09:50:15 3PAR_1674318 cli_command sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 15684} {geteventlog -debug -startt 1541339406 -endt 1541343012 -fprefix {} -tok 0 -fnum 0 -prstate 0 -prnode 0} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)