use strict;
my $str = '11 04 2018 04:42:49 192.168.1.103 <USER:INFO> Nov 4 04:42:49 3PAR_1674318 cli_command sw_cli {3paradm super all {{0 8}} -1 192.168.100.53 2314} {setcurrentdomain -} {}
11 04 2018 09:50:15 192.168.1.103 <USER:INFO> Nov 4 09:50:15 3PAR_1674318 cli_command sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 15684} {geteventlog -debug -startt 1541339406 -endt 1541343012 -fprefix {} -tok 0 -fnum 0 -prstate 0 -prnode 0} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
11 05 2018 01:52:17 192.168.1.103 <USER:ERRR> Nov 5 01:52:17 3PAR_1674318 cli_cmd_err sw_cli {3parsvc super all {{0 8}} -1 192.168.1.102 14090} {Command: getsralertcrit all Error: This system is not licensed for System Reporter features} {}
';
my $regex = qr/^.*?<\w+:(?<severity>.*?)>.*?3PAR.*?\s(?<command>[^\s]+)\s(?<process>.*?)\s\{(?<sessiontype>.*?)\{.*?\s-\d+\s+(?<sip>[^\s]+)\s(?<sport>[^\s]+)\}\s+(?<action>.*?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}