# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:<.*>)|(?<=>)(?:\<.*\n?.*\>))"
test_str = ("<p><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- $25mm to $50mm near term GLRV opportunity. If approved, they would invest in our commingled\n"
"fund.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- This was another critical step in Investcorp's investment process. In a\n"
"positive sign, they've decided to concurrently initiate operational due diligence on us and the GLRV fund/strategy.</font></font><br><font face=\"Helv\"\n"
"size=\"2\"><font face=\"Helv\" size=\"2\">- Overall an excellent, interactive meeting mainly focused on risk modeling and measurement, and how we use our \n"
"models/tools throughout the investment process to help source and implement trades; actively allocate risk across sub-strategies; as well as adjust the overall risk\n"
"taking in the strategy</font></font></p>\n\n"
"MEETING DETAILS:\n"
"None Available\n\n"
"NOTES:\n"
"<p><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- Investcorp is a NY based $10 billion global alternative investments manager with roots and a large\n"
"presence in the middle east.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- They are running ~$2 billion in traditional FoHFs AUM (in\n"
"addition to another $2 billion in other custom HF mandates) after closing on their SSARIS Advisors (another FoHFs) acquisition earlier this\n"
"year.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- The consolidation of their portfolio continues following the SSARIS acquisition\n"
"and he team is finally ready to allocate to new managers. FI Arb/RV is a space they are interested in again.</font></font><br><font face=\"Helv\" size=\"2\"><font\n"
"face=\"Helv\" size=\"2\">- We have the advantage of being "first in the door" as they assessed the space, since we've been talking to them about LRV\n"
"since early 2014.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.