const regex = /^((?!\s|\n).)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!\\s|\\n).)*', 'gm')
const str = `Iris-presenter | 5`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);