$re = '/^((?!\s|\n).)*/m';
$str = 'Iris-presenter | 5';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;