use strict;
my $str = 'Iris-presenter | 5';
my $regex = qr/^((?!\s|\n).)*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";