using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\*{2}\K(?:(?!\*/).)*(?=\*/\w+\d+)";
string input = @"/**word2 * super cool*/abc123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}