re = /\/\*{2}\K(?:(?!\*\/).)*(?=\*\/\w+\d+)/
str = '/**word2 * super cool*/abc123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end