$re = '~/\*{2}\K(?:(?!\*/).)*(?=\*/\w+\d+)~';
$str = '/**word2 * super cool*/abc123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);