const regex = /(?<!`)[\r\n]{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!`)[\\r\\n]{2}', 'gm')
const str = `Some random text...
text after break
haha text
\`Hey,
here is some text!
and here is the end =)\`
here is text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}