$re = '/(?<!`)[\r\n]{2}/m';
$str = 'Some random text...
text after break
haha text
`Hey,
here is some text!
and here is the end =)`
here is text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);