re = /(?<!`)[\r\n]{2}/m
str = 'Some random text...
text after break
haha text
`Hey,
here is some text!
and here is the end =)`
here is text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end